Nov 192017

1999 Ford Escort

Loaned daughter my extra car

Loaned daughter my extra car and while driving on freeway it started acting up. Loss of power, roughness and when she got home car stopped after making loud clunking noise. I pulled out all four spark plugs and the #4 plug was badly damaged. It also appears that the #4 piston is not moving up and down when crankshaft is turned by hand. I can also see some debris is the cylinder. I checked the oil and found that the level is about one and a half times over the full mark, I am guessing about 10 to 12 quarts of oil is present, why I don’t know. Can this amount of overfill cause engine damage?


The extra oil wouldn’t be the cause of the engine damage you described. I would look to see if the coolant or transmission fluid is low. One of the two may have gotten into the oil. Otherwise the oil may have been added after the engine started to make noise as an attempt at fixing it. Either way the engine is toast and will need to be replaced.

Nov 102017

Ford Taurus

Fan blowing on high

I drove my car to work and everything ran fine. I shut it off at work. Then after work restarted the car. It started right up and is running fine but the speedometer, blinkers, brake lights, heater/ AC ect are not working. The heater fan in the car is blowing on high even though it is “off” and the tachometer and fuel gauge is working. Ive never seen this before. Where should I start?


The blower working without being turned on is most commonly a sticking relay. However with all the other issue going on it might be more than that. I would start by checking the connections at the battery. Then isolate each circuit and check the connections and wiring harness. When wires cross or become brittle it can do some weird things.

2007 Ford Fusion SEL V6 3.0L Airbag Light On With B2290 Code

Auto Repair Questions, Ford Comments Off on 2007 Ford Fusion SEL V6 3.0L Airbag Light On With B2290 Code
Oct 312017

2007 Ford Fusion

Airbag Light Code B2290

It has airbag warning light turns on & passenger air bag light goes off, after few seconds of ignition/engine on. I hooked up the scanner and it gives B2290 code stating Occupant Classification System fault. Then I tried erasing the code but unable to do it as it comes right back on. I unplugged the wiring to OCM (or occupant detection / weight) sensor part#14B422 underneath the passenger seat, and then ofcourse U1900 came which says SRS module fault, but then I was able to erase the B2290 code, and not U1900. I also took it to a body shop as they have high end diagnostic tools, and they said recalibrating the OCM sensor should fix the issue, they tried to recalibrate it two times was successfully completed but the code didn’t go away. So they are suspecting that OCM sensor could be bad itself, and need to be replaced.
Its an expensive part $180, I don’t want to just replace it, if its really not required. Looking for 2nd opinion or suggestion to how to really identify the problem part.

Airbag warning light turns on

It has airbag warning light turns on & passenger air bag light goes off, after few seconds of ignition/engine on. I hooked up the scanner and it gives B2290 code stating Occupant Classification System fault. I tried erasing the code, but unable to do it as it comes right back on. Then unplugged the wiring to OCM (or occupant detection / weight) sensor part#14B422 underneath the passenger seat. And then of course U1900 came which says SRS module fault but I was able to erase the B2290 code and not U1900.

Then I took it to a body shop as they have high end diagnostic tools and they said re-calibrating the OCM sensor should fix the issue. They tried to recalibrate it two times was successfully completed but the code didn’t go away. So they are suspecting that OCM sensor could be bad itself and need to be replaced. Of course they didn’t allow me to watch the process they are doing so I don’t have full details on what all they did.

Inquired with dealership

I inquired with dealership over phone about it and as per them following spec. It needs to replace all 4 sensors underneath the seat including rail sensors and all. So I can’t even locate those 4 sensors they talked about at fordparts.com with my car details. I also couldn’t locate those many plugs & sensors underneath the passenger seat in my car. So I am not sure how much to trust that information.

Its an expensive part $180. I don’t want to just replace it if its really not required. And thus may not fix the problem. Looking for 2nd opinion or suggestion to how to really identify the problem part. And if there is a way to test if the sensor is really bad by jumping/shorting the wires, resistance test etc. etc.


Ford Code B2290

Occupant Classification System Fault which is the weight sensor in the passenger front seat. The weight sensor may need to be reset with a Ford diagnostic computer if the seat was replaced.

If you swapped the entire seat the new sensor needs calibrated.

Ford states that whole bottom part of the seat has to be replaced with module+sensor factory installed for it to work. So replacing only bladder or module wont work.

Oct 312017

1995 Ford E150

No Heat

I put it in the shop for them to fix problem. It came back running worse. Turns out they took out the proair 800 and bypassed it so coolant was circulating but not enough since I was still overheating. I redid everything they did and it runs better. I put in some radiator sealant and that sealed a few things I didn’t want it to. Mainly the overflow which helped keep running just a little longer. I fixed that but it still keeping it running a bit longer.

I noticed when I did the by pass in the back that there isn’t a really marked as to which hose to which so I may have that wrong plus the wiring that I plugged back together there is one I couldn’t find. And two that plugged into fuses back there didn’t say which fuse they went too.

I have since developed a leak in radiator and it overheats. Other than that the van runs great. Way better than before but I can’t afford another radiator or even coolant at this point but before when proair 800 was still bypassed I had heat. When I rerouted the lines in back is when all the cold air just stayed on. Feels like air conditioning is stuck. But I do get warm air right when it starts getting really hot please give me the very best guess possible is it the wire I didn’t plug in. Are the two hoses reversed? Or is it just that I need a new radiator. I live in Alaska and heat is crucial.


Best guess is there is an air pocket in the system. And it will be almost impossible to for the system to work if it has a leak. You need the cooling system to be leak free. Needs to be completely filled with 50/50 mix of coolant/water and bled of no air. Straight coolant or straight water will cause it to overheat even in perfectly functioning cooling systems.

Another thought I had was if both heater hoses are hot, and it is blowing cold it may be that the vacuum hoses didn’t get hook back up right on the back of the control head. If there is a vacuum leak the mode door actuator won’t work correctly.

Oct 242017

2005 Ford Explorer

Engine will just die

This vehicle runs well and has plenty of power, but occasionally the engine will just die. It can happen at 10 mph or 60 mph. It will crank back up and run. Appears to be an intermittent problem. Pulled two codes from the computer:
P1633 KAM (Keep Alive Memory) Voltage Too Low
P0462 Fuel Level Sensor Low Input

I don’t know that these codes have anything to do with the problem we’re having with the vehicle. I’ve checked some of the simple stuff like making sure there is plenty of fuel in the tank, and I checked the battery voltage (a good 12.6 volts).

What do you think?


I wouldn’t think that these codes have anything to do with the engine intermittently dying on you. Unfortunately this is one of the most difficult problems to diagnose. If the engine wouldn’t restart it would be as simple as just figuring out if it isn’t getting fuel or spark. But since it starts right back up it make it that much more difficult. I would guess a loose connection or a failing sensor. As for which one, difficult to tell. Unfortunately in this case it would be more cost effective to let the problem get worse in order to know exactly what to repair/replace. No need to through parts at it if you don’t have to.

What does code P1633 mean?

P1633 means that the powertrain control module (PCM) has detected low voltage on the keep alive memory circuit. This is the circuit that supplies constant battery voltage to the keep alive memory portion of the PCM so it can retain information regarding fuel control, idle control and transmission control adaptive strategies to name a few. If the battery is disconnected or voltage drops below 10.5 volts this code will be set. If the battery has not been disconnected then the circuit will need to be checked for opens or high resistance in the wire, shorts, blown fuse, high voltage r/f interference from ignition or charging system components, or the PCM being being faulty itself.

Ford Code P1633

KAM Volt Low

Code P1633 Probable Causes

  1. Sensor or solenoid faulty
  2. Connector terminal contact is damaged or corroded
  3. Wire harness – Check harness for correct voltage, open, short to ground or short to voltage
  4. Update control unit software – Check for the latest control unit update
  5. Powertrain or Engine Control Module faulty
  6. Battery voltage low

Ford Code P0462

Fuel level sensor A circuit low input

Code P0462 Probable Causes

  1. Sensor or solenoid faulty
  2. Connector terminal contact is damaged or corroded
  3. Wire harness – Check harness for correct voltage, open, short to ground or short to voltage
  4. Update control unit software – Check for the latest control unit update
  5. Powertrain or Engine Control Module faulty
  6. Battery voltage low

Sources: Justanswer, Chilton

Oct 232017

2006 Ford Taurus

I have been throwing parts at this car trying to fix it. It started with multiple check engine codes P0300 and a few more P03XX ones I cannot remember. But they all had to do with misfire. I replaced the plugs and the coil pack. While replacing the plugs, #5 cylinders plug was missing the tip of the plug so I know it was not firing. After replacing the parts it ran great but code P0300 came back. Checked for vacuum leaks, tested all the injectors and found one that may have been weak. Then I replaced the upper intake manifold and all the injectors along with the EGR Valve, Mass Air Flow, EGR Vacuum Solenoid, and the Cam Sensor. I figured I would have got it with all that but nope.

I now get P0402 and still P0300 so now I am thinking I will go ahead and replace the Camshaft Synchronizer and the crank sensor. Not sure what else I could be missing but I am willing to try anything at this point. If anyone has any other ideas, I am going to pull the plugs and recheck them along with the plug wires. I have rechecked the wiring positions and they are in the correct order.


In my experience with code P0402 you will need to replace 3 components. The EGR, EGR Regulator and DPF (Differential Pressure Feedback) EGR valves. You will also want to remove the valve tubes and make sure all are clean and clear of obstruction. Do the same for the ports they connect to. As for the Po300 misfire code should clear up once you take care of the EGR issues.

Exhaust Gas Recirculation (EGR) System Components — Exploded View

EGR compnent location diagram 2006 Ford Taurus

Item Part Number Description
1 14A464 Exhaust gas recirculation (EGR) vacuum regulator valve electrical connector
2 N620479 EGR vacuum regulator valve nuts (2 required)
3 9J489C EGR vacuum regulator valve
4 Vacuum tube connector-to-EGR vacuum regulator valve (part of 9E498)
5 9E498 EGR vacuum tube
6 Vacuum tube connector-to-EGR valve (part of 9E498)
7 9E444A Differential pressure feedback EGR sensor
8 14A464 Differential pressure feedback EGR sensor electrical connector
9 9D476B EGR valve gasket
10 9E444A EGR valve
11 Exhaust manifold-to-EGR valve tube fitting (part of 9D477E)
12 Exhaust manifold-to-EGR valve tube nut (part of 9D477E)
13 9D477E Exhaust manifold-to-EGR valve tube
14 W500224 EGR valve bolts (2 required)
15 9P761A Differential pressure feedback EGR sensor vacuum hoses (2 required)

Ford Code P0402

Code P0402 Description: Exhaust Gas Recirculation Flow Excessive Detected

Code P0402 Possible Causes

  1. Sensor or solenoid faulty
  2. Connector terminal contact is damaged or corroded
  3. Wire harness – Check harness for correct voltage, open, short to ground or short to voltage
  4. Update control unit software – Check for the latest control unit update
  5. Powertrain or Engine Control Module faulty
  6. Exhaust leaks or restrictions
  7. EGR components clogged, dirty or leaky
  8. EGR valve damaged/defective

Oct 212017

Ford Crown Victoria

The headlights do not always come on when operating the high/low switch. Sometimes they come on, however they don’t come on every time. I’d like to know if there is some part, other than the h/l switch that will cause this intermittent situation? Thank You for your knowledgeable response.


When looking at the diagram it appears the only options would be the wiring, the switch or the Lighting Control Module. If equipped with DRL (Daytime Running Lights) there is the addition of the DRL Module.

Headlights

Headlights without DRL wiring diagram

(best viewed in Chrome or Firefox)
2005-ford-crown-victoria-headlights-headlamps-circuit-w-o-drl-1-of-1

Headlights with DRL wiring diagram

2005-ford-crown-victoria-headlights-headlamps-circuit-w-drl-1-of-1
Oct 182017

Ford Ranger

Diagnosed a bad throttle position sensor. Installed a new one. Ran great for about a minute. Went back to running rough. Installed another new tps. Again it ran good for about a minute. Then it ran rough again. With the voltmeter I confirmed I had good 12 volt power going in. On the third wire I confirmed a good ground loop. But on the signal wire it should read 0.9 volts on closed throttle and 5.0 volts on wide open throttle. It gave 0.3 volts closed throttle to wide open throttle. Could my signal wire be grounded somewhere? Or could my computer be fried?


Throttle Position Sensor

tps connector diagram 2003 Ford Ranger

Testing for short or open in wiring harness

Check TP Circuit for open in harness
  • Turn ignition switch to off position. Leave TP sensor disconnected. Disconnect PCM connector(s). Inspect connector for loose, damaged or corroded terminals, and repair as needed.
  • Using a digital multi-meter, measure resistance of TP circuit between PCM harness connector and TP sensor connector.
  • If resistance is less than 5 ohms go to next step below. If resistance is 5 ohms or more, repair open in TP circuit.
Check TP Circuit for short to SIG RTN or PWR GND in harness
  • Ensure PCM is disconnected. Disconnect scan tool from Data Link Connector.
  • Using a Digital multi-meter, measure resistance between TP circuit, and SIG RTN and PWR GND circuits at PCM harness connector. If either resistance measurement is 10k/ohms or less, repair short between circuits.
  • If both resistance measurements are more than 10k/ohms, replace the PCM.

Oct 092017

2002 Ford Mustang

I need to see which color wires and what holes they plug in on engine wiring harness that control fuel injectors, coils, etc. It has 25 to 30 pins.


I shall provide you with the engine wiring diagram in 3 parts. (best viewed with Chrome or Firefox)

Engine Wiring Diagram 2002 Ford Mustang GT

2002-ford-mustang-gt-engine-controls-1-of-3
2002-ford-mustang-gt-engine-controls-2-of-3
2002-ford-mustang-gt-engine-controls-3-of-3